TestNamespace Namespace

Reference Library
TestNamespace Namespace
Namespaces > TestNamespace
This is experimental documentation.
Syntax
C# Visual Basic Managed C++
namespace TestNamespace
Namespace TestNamespace
namespace TestNamespace
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
public class | StoredNumber | A test class.
(c) Microsoft Corporation. All rights reserved. Send comments about this topic to Microsoft.


StoredNumber Class

 select="concat(/document/reference/containers/container[@namespace]/apidata/@name,'.',/document/reference/apidata/@name)"
Reference Library
StoredNumber Class
Namespaces > TestNamespace > StoredNumber
This is experimental documentation.
A test class.
Syntax
C# Visual Basic Managed C++
public class StoredNumber
Public Class StoredNumber
public ref class StoredNumber
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoredNumberNew(Int32) | Initializes the stored number class with a starting value.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode() | Serves as a hash function for a particular type. GetHashCode() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType() | Gets the Type of the current instance. (Inherited from Object.)
 | Increment() | Incriments the stored number by one.
 | Increment(Int32) | Incriments the stored number by a specified step.
 | MemberwiseClone() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets the stored number.
Inheritance Hierarchy
Object
StoredNumber
(c) Microsoft Corporation. All rights reserved. Send comments about this topic to Microsoft.


.ctor Constructor

.ctor Constructor
Namespaces > TestNamespace > StoredNumber > StoredNumberNew(Int32)
This is experimental documentation.
Initializes the stored number class with a starting value.
Syntax
C# Visual Basic Managed C++
public StoredNumber (
    int value
)
Public Sub New ( _
    value As Integer _
)
public:
StoredNumber (
    int value
)
Parameters
value ()


Increment Method

Increment Method
Namespaces > TestNamespace > StoredNumber > Increment
This is experimental documentation.
Members
Icon | Member | Description
 | Increment() | Incriments the stored number by one. (Inherited from StoredNumber.)
 | Increment(Int32) | Incriments the stored number by a specified step. (Inherited from StoredNumber.)


Increment Method

Increment Method
Namespaces > TestNamespace > StoredNumber > Increment()
This is experimental documentation.
Incriments the stored number by one.
Syntax
C# Visual Basic Managed C++
public void Increment ()
Public Sub Increment
public:
void Increment ()


Increment Method

Increment Method
Namespaces > TestNamespace > StoredNumber > Increment(Int32)
This is experimental documentation.
Incriments the stored number by a specified step.
Syntax
C# Visual Basic Managed C++
public void Increment (
    int step
)
Public Sub Increment ( _
    step As Integer _
)
public:
void Increment (
    int step
)
Parameters
step ()


Value Property

Value Property
Namespaces > TestNamespace > StoredNumber > Value
This is experimental documentation.
Gets the stored number.
Syntax
C# Visual Basic Managed C++
public int Value { get; }
Public ReadOnly Property Value As Integer
public:
int Value {
    int get ();
}


Namespaces

Namespaces
Namespaces > R:Project
This is experimental documentation.
Namespaces
Namespace | Description
TestNamespace |