Scott Hanselman

New Release of WatirMaker now WatirRecorder

July 25, '06 Comments [5] Posted in Ruby | Watir
Sponsored By

Watirrecorder1Rutger Smit has given the original WatirMaker an overhaul and we're re-releasing it as WatirRecorder++. Here's the original screencast if you want to see what it does. A roadmap will follow soon. Thanks Rutger!

This version compiles and runs under 1.1, but it upgrades smoothly to 2.0, so we'll probably do that one day. We're in the process of setting up an Open Source BSD Project at CodePlex.com so if you've made changes yourself, or you want to join up, now's the time. We'll get the source uploaded as soon as the permissions are setup. If you become a developer or want the source, you'll be able to interact with the Team System source control system using a number of clients. Be sure to read the manual.

UPDATE: We had some trouble getting everyone access on CodePlex so we're putting WatirMaker/WatirRecorder up on OpenQA.org, where Watir itself is hosted.

You can check out the source anonymously using the Subversion URL http://svn.openqa.org/svn/watir-recorder/trunk You can get the source by doing the following:

svn co https://svn.openqa.org/svn/watir-recorder/trunk

If you've never installed Watir, here's the easiest possible thing to do:

  • Install the Ruby One-Click Installer.
  • Open cmd.exe and type "gem install watir"
  • Install WatirRecorder++, hit Start, do some stuff (do NOT use the keyboard to submit forms). Hit stop, and playback.
  • Now, STOP everything and remind yourself that this is a jump-starter, that's it.

Enjoy.

File Attachment: WatirRecorder_Setup_Lite.msi (2858 KB)

As an aside, keep an eye out for FireWatir. It's tricky to install and requires a number of bleeding edge things, but it's very shiny.

About Scott

Scott Hanselman is a former professor, former Chief Architect in finance, now speaker, consultant, father, diabetic, and Microsoft employee. I am a failed stand-up comic, a cornrower, and a book author.

facebook twitter subscribe
About   Newsletter
Sponsored By
Hosting By
Dedicated Windows Server Hosting by ORCS Web
Tuesday, July 25, 2006 4:56:13 PM UTC
Is there a valid reason that the installer won't let me continue without .NET 1.1? I've only got 2.0 installed on this machine (well, and some 3.0 CTPs. :-p).
Tuesday, July 25, 2006 5:00:29 PM UTC
From the text above ;)

"This version compiles and runs under 1.1, but it upgrades smoothly to 2.0, so we'll probably do that one day."
Scott Hanselman
Tuesday, July 25, 2006 5:23:18 PM UTC
Thanks for this guide! It's just the hand-holding I needed to inspire me to take the time and see what the fuss is about.
Wednesday, July 26, 2006 1:00:17 AM UTC
Love the new gui. I just installed watir last week to see if we can replace our nunitasp tests. Definitely will try watirmaker, Thanks!
Thursday, July 27, 2006 5:00:01 AM UTC
Is it just me, or does it not seem to record the activity inside textarea fields?
Comments are closed.

Disclaimer: The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.