Scott Hanselman

Diary of a Vista RC1 Install - Upgrading My Main Machine to Windows Vista RC1

September 8, '06 Comments [17] Posted in Reviews
Sponsored By

VistadevicemanagerBEGIN - 10:50 PM 9/7/2006: Pray for me. I'm upgrading my main machine at home to Windows Vista Ultimate RC1 right now. We'll see if this list of tools is compatible with Vista...starting now.

COMPATIBILITY CHECK - 11:04 PM 9/7/2006: Hm...this doesn't bode well. I don't have a QuickCam installed, much less three. Not only that, but the Logitech QuickCam Express always supported in Windows XP with drivers that shipped with the OS; I wonder why that changed?

Looks like problems with SQL Server 2005 as well. I think I'll install SQL SP1 first. Weird about Nero, I already uninstalled that.

The following applications/drivers are not supported in Windows Vista
    The following devices will not work until the device driver software is updated. After the installation is complete, run Windows Update and check to see if there are any available updates for your devices. If this does not resolve your problem(s), contact the device manufacturer for updated driver software for these devices. :
    • Imaging devices: Logitech QuickCam Express
    • Imaging devices: Logitech QuickCam Express #3
    • Imaging devices: Logitech QuickCam Express #2
    Current versions of the following programs will not work with Windows Vista. After the installation is complete, get updated versions that are compatible with Windows Vista:
    • IntelliType Pro 5.x
    • Microsoft SQL Server 2005
    • Microsoft Powertoys for XP
    • ATI Control Panel
    • Nero 7 Premium
    • Sun Java Scheduler

EXPANDING FILES - 12:50 AM 9/8/2006: Oy. Still going. There's five steps here, Copying, Gathering, Expanding, Installing and Completing. I'm 21% into Expanding. Not sure what we were gathering or from where. The copying from DVD phase took about 15 minutes, but the "gathering" took forever. Now we're expanding. This is a 3GHz P4 on an Intel 925 MB with an SATA 7200 RPM Drive and 2 gigs of the fastest RAM the MB can take. Any one have any ideas why this is taking so long? Even as I type this I can hear the hard drive running like rain on a metal roof. Still 21% into Step 3. Time for bed methinks. This doesn't bode well for Mo's commodity Celeron with 512 MB of RAM. Hm...not at 22% yet...

PLEASE WAIT...PREPARING TO START... - 1:11 AM 9/8/2006: I nodded off there for a sec...I see a gray screen that says "Please wait a moment while Windows prepares to start for the first time." Not "while Windows starts for the first time," but "prepares to start." Hurry up and wait. Watching the dots........we are at 2 hours 21 minutes elapsed upgrade time thus far (counting the 6 minutes it took to apply SQL2k5SP1 after that warning above)....

BLACK SCREEN - 1:14 AM 9/8/2006: Rebooted automatically...I see a black screen...and a mouse cursor! Now, "completing upgrade"...oh, I thought we were starting. Psyche. Still upgrading...same image duplicated on both monitors, not sure if it's detected that I have two yet...cycling ellipses continue. Little trivia for you, did you know that ellipsis is Greek (e??e??e??) for omission? So far my upgrade is omitted.

MONITOR FLASHING - 1:18 AM 9/8/2006: My secondary monitor just flashed off and disappeared, it's black now and the mouse won't move off the edge of the primary. I think we've just reached the event horizon of this upgrade installation. Not sure if it's this event horizon or this Event Horizon. God help me if it's the latter.

COMPLETING UPGRADE - 1:21 AM 9/8/2006: Still "Completing Upgrade..."

--- The Next Day ---

CHECKING YOUR SYSTEM'S PERFORMANCE - 8:05 AM 9/8/2006: Ah! I awoke today to find a sea-green  screen asking me to press OK and confirm the time, time-zone and location. Not sure why it couldn't have gleaned all that information over th' intraweb, but que sera sera. I pressed OK, waiting for my Vista Desktop to appear in all its glory...and...Progress Bar! "Checking Your System's Performance..." Poop. I'm going to work.

PREPARING YOUR DESKTOP... - 8:15 PM 9/8/2006: The end is near! I see the fifth visual indicator to "hang on, we're really doing something, your computer ISN'T locked up!" This one is a spinning circle.

SUCCESS! - 8:27 PM 9/8/2006: I can see my stuff! Took a while, but pretty much all is well.

All the devices work save a generic random USB Camera with no Manufacturer. Not sure why the original driver didn't suffice..now it wants the disk that I don't have. I didn't like this camera anyway. Pretty good.

Now...what's this about be being a 4.2? Is that out of 5? 10? 100?

Myupgradedvista

UPDATE/CONCLUSION: For the most part everything works. Like 95% of things I use. Here's the jist:

  • The default Windows video drivers for my ATI Radeon 9800 Pro were poo. I got the Beta ATI Catalyst Drivers and the video is working OK.
    • Video Playback on the secondary monitor is unusable, as is Media Center. The Primary Monitor is fine.
  • Having Media Center (via having upgraded from XP Pro to Vista Ultimate) makes it almost worth the hassle for the whole thing. I just need to figure out a remote control situation. Still, the new Media Center is pretty cool, even if it (currently) is a Frankenstein's Monster of the new and old. If you're familiar with Media Center you'll find old looking sections that are jarring after you play with the new stuff.
  • I can't get Virtual PC's Network Drivers to work, so my VPCs have no networking...not sure what's up with that.
  • FinePrint doesn't work, it seems to have been quaranteened (incorrectly) by Windows Defender.
    • I can't figure out the interface to Defender...some items are disabled, but it's not allowing me to enable them.
  • TrueCrypt works, thank gosh, but you have to Shift-Right-Click and Run As Administrator to get it's drivers loaded.
    • Interestingly you can't make a shortcut and Shift-Right-Click the link. An irritating shell bug.
  • Opening new Tabs in IE7 is unacceptably slow.
  • There's some problems with Acronis True Image, but I'm hoping that'll get fixed soon.
  • Performance is a little slow, maybe 15% slower than it should be, but I think if I turned of the Flashy UI it'd be snapper. We'll see when I run it on Mo's little machine.
  • Windows Defender has a cheesy UI in that it's not integrated with the whole "Suite" of Security Stuff. There's Anti-Virus, Firewall, Phishing, Defender - you'll find yourself running around trying to find out where things are.

All in all, I'm happy I did it and I'm upgrading Mo's machine and my Media Center server as well. This will be the first time since 1995 that the whole family was running Beta software. I'm impressed so far.

About Scott

Scott Hanselman is a former professor, former Chief Architect in finance, now speaker, consultant, father, diabetic, and Microsoft employee. He is a failed stand-up comic, a cornrower, and a book author.

facebook twitter subscribe
About   Newsletter
Sponsored By
Hosting By
Dedicated Windows Server Hosting by ORCS Web
Friday, September 08, 2006 5:54:03 AM UTC
Good luck. I haven't made that plunge yet but plan to this weekend. Maybe we'll both be repaving our systems back to something that works.
Friday, September 08, 2006 6:11:26 AM UTC
Me too, and I think you'll be sorry.

I like Vista a lot, actually-- the refined windows/start menu is worth its weight in gold-- but it's not so hot on the compatibility front, particularly for tweakers..
Friday, September 08, 2006 6:25:16 AM UTC
if you find compat issues, let me know and i'd be happy to report them (although you can to through Connect. I'd be happy if you figure out how to get the notepad2/++ replacement for notepad.exe in vista -- it's a bit more protected...
Friday, September 08, 2006 12:11:54 PM UTC
I started the Vista plunge a couple of nights ago and took the upgrade path like you did. It sure didn't take 30 minutes like some are reported for a clean install! Unlike you, though, I went to bed and got up the next morning and was greeted with a hanging task that I had to end... (that was the first reboot). All in all, it took me two nights to install. <br><br>But I do like it now.
Friday, September 08, 2006 12:27:06 PM UTC
I feel kinda like the guys in the second wave, storming the beaches of Normandy. I can see all those dead and dying geeks on the Vista shores, but yet I feel compelled to keep moving forward, to launch myself from the safety of my boat into the churning waters lapping up onto the beach. Will I be the one to safely sneak past the compatability nest as it spits out rapid-fire warnings, rat a tat tat. Oh sh*t. Scott just got hit in the right eye and is partially blind. Maybe Corpsman MaxiVista can get to him in time.
Friday, September 08, 2006 3:10:37 PM UTC
I didn't think Event Horizon was really all that bad until the last half hour. Then it went off the deep end and Sam Neill turned into a demon. That's my pet peeve with movies. We get 1.5 hours into it, and then the writers quit trying.

So anyway, do I get my geek card confiscated if I choose to put off the move to Vista until RTM?
Friday, September 08, 2006 6:06:43 PM UTC
Sounds like the exact things that went over the XP triers back then.
but after all, XP turned to be a great workstation OS, even if it started to rock only at SP1.
I wouldn't have done so to my primary PC, since I partly work from home, and bread is better earned on a well working PC.
@Joe - liked the observation.
@Cam - right about the movie, and (maybe) right about the decision. it's a matter of spare time and the passion for kewl stuff, I guess, and if you don't have both, then putting it off is smart, however very un-geeky.
Friday, September 08, 2006 6:36:12 PM UTC
I noticed Nero won't install... you get any NRG files to mount with any other tool? Or figure out how to manually install ImageDrive?
David Betz
Friday, September 08, 2006 7:33:43 PM UTC
"Time for bed methinks."

As IF.
Dave P.
Friday, September 08, 2006 7:45:49 PM UTC
I feel your pain... after many hours of the bouncing cursors, progress bars, and of the such, I'm 2 for 2 of different Dell models booting to a BSOD. Appears that the onboard Adaptec RAID controllers are not happy with the default HAL. Fun times.

Odd... I never had SQL Server 2005 show up though on the prelim. Perhaps the clean install sounds like a fun treat. ;) G'luck on your upgrades!
Saturday, September 09, 2006 3:22:38 AM UTC
So what the heck happened? Does it live?

Report! :)

Is anyone there...
Saturday, September 09, 2006 4:19:03 AM UTC
I believe that the "Gathering Files" stage is actually backing up your origninal installation. I tried to upgrade my wife's Lifebook and on final reboot got a BSOD. No idea what is doing it. It's a low level driver. Don't even get to the scrolling progress screen.

The upside is that when you reboot there is a "put everything back the way it was" option. AND IT WORKS!!

No trace of Vista and all working as it was.

You mileage, as always, may vary but colour me truly impressed.

Dave
Saturday, September 09, 2006 5:40:18 AM UTC
I only got a rating of 1.0 out of beta 2...
Saturday, September 09, 2006 7:36:16 AM UTC
> Performance is a little slow, maybe 15% slower than it should be, but I think if I turned of the Flashy UI it'd be snapper.

Actually, I find that turning off Windows Defender (real-time in particular) and System Restore helps a lot with performance in Vista. Aero doesn't make much difference either on or off, as long as your video card is decent/modern (and yours is).

My hard drive was going absolutely nuts last night after a few driver installs. I turned off System Restore and the drive *instantly* went silent. I guess creating those checkpoints is pretty invasive stuff.

Also Windows Experience Index is not on a scale of 1-5, because my video card scores a 5.9. More on that here:

Have You Ever Been Windows Experienced?
http://www.codinghorror.com/blog/archives/000678.html

Monday, September 11, 2006 6:39:33 AM UTC
Scott,

If you want a cool way to remote control your new Vista Media center, I can get you a license for our control daemon that enables TCP/IP and RS232 control...

My way of saying thanks for the blog and podcast.

Michael
http://www.autonomichome.com/
Sunday, September 17, 2006 5:12:43 PM UTC
Hi Scott,

I too upgraded to Vista RC1. It took around 30 minutes installing from the DVD, formatting my xp drive in the process.
I didn't install any of my development environment, just did some browsing and talking on messenger.
Everything seemed to be running great. So of course I had to try it again. This time I decided to try and take advantage of my AMD64 and install the 64 bit version.

This time it took alot longer to install even though I installed from the DVD again. I lost track of time and left it over night. Once up and running I started browsing and talking on messenger again. (I have my laptop to do dev on so was not totally incapacitated). After a little while I started seeing issues. My logitech G15 keyboard, with the 64 bit drivers installed (XP), apparently stopped working. That is what Vista told me anyway.
A couple of minutes later I got a security/C++ error from messenger, from inside newstor.cpp. This dialog appeared a number of times. So I rebooted and started using it again. Unfortunately after only a few minutes of running the same errors occoured. Other applications were reported as not being stopped.

So here I am back in the, (at least on my hardware) more stable, 32bit version.
Maybe I missed installing something that would have made the 64bit version work better. My system receives a score of 4.0 with the CPU pulling it down.(Image linked as homepage.)

The only thing that is not great right now is that my secondary monitor does not seem to like the transparency effect. It is an old 17" CRT and when I drag a window onto it the image looks like a chess board which flickers black everytime I mouse over a button on it. This is probably the beta drivers that I have for my gfx card, or maybe the monitor is about to explode. Either way I am back to a single monitor for now.

So now it is time to try setting up the dev environment. Do you have an update on any of the tools from your list not working?

(I just had to turn off the protected mode in i.e. to be able to see your confirmation code.)
Thursday, September 21, 2006 2:47:52 PM UTC
QuickCam drivers DO work under Vista, at least RC1 for sure. What does NOT work is the installer or the additional software. However, if you go into the device manager, you should see an unnamed device with no driver (it should be indicated with a yellow exclamation point I think). Anyway, that's your camera. Click it and elect to locate a driver for the camera, then point it to the Drivers directory on your CD. In a few moments your camera will be up in running under Vista. Works fine with Skype and what have you.
Comments are closed.

Disclaimer: The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.