Scott Hanselman

ATI Radeon 9800 Vista Drivers - Flash and Windows Video Stops or Stutters

May 20, '07 Comments [13] Posted in Musings
Sponsored By

I've googled my brains out about this and I can't find anything. For some reason, on my Vista Desktop Video only plays for a few frames, then stops. Sometimes it stops completely, other times it just stutters severely. This happens in both Flash and Windows Media video.

At this point, I'm debating a new Video card. Does ANYONE else have this problem? I've tried contacting ATI and it's virtually impossible to get a straight answer from them.

About Scott

Scott Hanselman is a former professor, former Chief Architect in finance, now speaker, consultant, father, diabetic, and Microsoft employee. He is a failed stand-up comic, a cornrower, and a book author.

facebook twitter subscribe
About   Newsletter
Sponsored By
Hosting By
Dedicated Windows Server Hosting by ORCS Web
Sunday, May 20, 2007 11:19:55 PM UTC
It happens to me too ... I even tried with K-Lite pack ... but there is no improvement at all.
Sunday, May 20, 2007 11:26:33 PM UTC
Vista display drivers are not yet in good shape. Please avoid NVIDIA. I have three computers (laptops & a desktop) with nvidia cards and their performance is really really bad.

ATI has by far the best support for vista.
Monday, May 21, 2007 12:01:04 AM UTC
Scott, maybe you can try to adjust the "Hardware acceleration" options from Troubleshoot tab of Display property, although you will lost the *BEST*(who knows if we really need the full HW acceleration) performance, but sometimes it just solves the urgent problem.
Monday, May 21, 2007 1:02:13 AM UTC
@Damir - It's sad, but it's comforting that I'm not the only one. So you agree it's the drivers?

@darkthread - Good idea, I'll try that.
Monday, May 21, 2007 2:47:41 AM UTC
my thinkpads,, regardless of xp or vista have it. i've disabled almost every device/driver/program on them, to no avail.

oddly enough (not), my macbook doesn't have this problem.

Frankie Fives
Monday, May 21, 2007 6:55:04 AM UTC
I have a desktop (Dell Dimension 8300) with an ATI Radeon 9800 Pro video card and I am not experiencing any such difficulties with the Vista drivers from ATI.
Monday, May 21, 2007 9:48:10 AM UTC
@scott: Strange but it could be the driver issue. I believe that there are some conflicts with other drivers. I had no time to search for a solution yet but I will try to reinstall the latest drivers again.
Monday, May 21, 2007 11:59:36 AM UTC
See link about stuttering video and ReadyBoost. Related to your problem? Maybe or maybe not.
http://mtaulty.com/CommunityServer/blogs/mike_taultys_blog/archive/2007/05/21/9344.aspx
Kerry Jenkins
Monday, May 21, 2007 5:55:17 PM UTC
Scott, what is it about Vista that makes people endure all of these regressions when it comes to simple hardware support? I personally haven't seen anything compelling enough to make me leave the stability of XP. I know you're an early adopter and all, but at some point when it affects your day-to-day activities, is it time to jump back in the old boat?
Shawn Wheatley
Monday, May 21, 2007 8:19:36 PM UTC
Scott, what is it about Vista that makes people endure all of these regressions when it comes to simple hardware support?


I'm not Scott, but I'll try to chime in: people do not expect these regressions. They want the latest and the greatest and according to reviews and articles and blogs entries and whatnot, their system should work just fine. So people jump in, install Vista and then if there's a problem, they try to fix it.
I don't think anyone would go ahead knowing in advance that their system won't work. Like flying (on a plane): you know that the plane could crash but there's a very, very small chance it'll crash and a lot larger it'll fly just fine.
Tuesday, May 22, 2007 1:00:08 PM UTC
I dont have a solution, only an observation. I have a Dell with an ATI card that seems to go haywire occasionally when going into sleep mode. I end up with a very jaggy looking messed up display that is mostly pink. Larry O'Brien described something similar on his machine - also with an ATI card. This entire display issue is just one big annoying mess. I wonder how they calibrate new PC's that have Vista factory installed. Mine is an upgrade from XP.
Wednesday, May 23, 2007 6:00:56 AM UTC
Disable ReadyBoost
Wednesday, May 30, 2007 7:51:38 AM UTC
When I upgraded my shuttle-sized box to Vista, I managed to toast my 9800 Pro within about two weeks - I originally put this down to the fact that you just can't expect to get away with running high-powered graphics cards and hungry processors in such a tiny box without placing it in a fridge, but perhaps an element in the death of my old trusty graphics card could have been driver related.

Still, it's people like us who upgrade early who help encourage hardware manufacturers to get their drivers working properly on the newly-released operating systems - we just have to accept the fact that being an early adopter has risks!
Comments are closed.

Disclaimer: The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.