Scott Hanselman

TODO: Update your DVD-ROM's Firmware

September 28, '07 Comments [3] Posted in Musings | Tools
Sponsored By

Wow, ONE more device to flash with new Firmware. I'd completely forgotten that DVD-ROM players have firmware too (what doesn't?) and I'd gotten used to devices that got auto-flashed a driver, like some wireless cards.

Seems to me that firmware flashing is not only something that my Mom and Dad wouldn't know how to do - they shouldn't have to.

Regardless, I started getting a weird error when burning DVDs, and I noticed this string in IMGBurn:

image

I figured that was a model and version string so I google'ed...

  • The Firmware Page - A portal full of every firmware for every kind of optical drive. Man, there's a forum for everything in the world.
  • CDRinfo's Firmware Page - A list of updates to drive firmware.

I ended up at the Lite-On Firmware Download page, got their little program. It worked on 64-bit also. It would have SUCKED if it hadn't. Flash, and I'm all set, updated to LLOC.

Flash Program for LITE-ON DVDRW LH-20A1H

Of course, firmware wasn't my problem, although it's nice to be up to date.

If you get "Failed to lock volume for exclusive access" while burning a disk, use ProcessExplorer and go to the Find menu item and search for "CDROM" to see the processes that have it open.

About Scott

Scott Hanselman is a former professor, former Chief Architect in finance, now speaker, consultant, father, diabetic, and Microsoft employee. I am a failed stand-up comic, a cornrower, and a book author.

facebook twitter subscribe
About   Newsletter
Sponsored By
Hosting By
Dedicated Windows Server Hosting by ORCS Web
Friday, September 28, 2007 2:16:29 AM UTC
Heh, yep, been there, done that. Be careful when flashing your drives, though, putting the wrong firmware in will cause you griefs to no ends. I was managed to render my machine unbootable (wouldn't pass the POST) because of a firmware flashing gone wrong with my DVD drive (it caused the drive to not respond correctly to the IDE bus commands, which really messed things up).

I ended up having to boot the machine with another drive from another laptop (otherwise, the machine wouldn't recognize the drive when I plugged it in later on because it deactivated the bay during boot if no drives were found), booting into DOS with a bootable disk, plugging the dead drive in and using some scary tools to reflash the drive into a working condition.
Friday, September 28, 2007 11:30:34 AM UTC
Obnoxious copy protections schemes can make this sort of thing necessary -- I couldn't get Quake 4 to install on either my machine or my wife's without flashing the firmware on the DVD drives involved.
Anthony Bellissimo
Friday, September 28, 2007 12:03:44 PM UTC
Uh-oh. Is it the Ultimate Developer Machine Sony NEC Optiarc giving you this problem? I ask because I am sitting at home with a freshly baked copy of Vista 64 waiting for the last bits of my Basic/Premium/Deluxe Coding Horror Rig Mashup (which should include the same drive).
Ben Taylor
Comments are closed.

Disclaimer: The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.